8

Which do you prefer of these two? The goal is the same. If bar is null then make foo null and avoid the exception. In other languages there is the ?. operator to help with this.

foo = bar == null ? null : bar.baz();
foo = bar != null ? bar.baz() : null;

I ask because I feel like the "English" of the first example is easier to read and has less negations so it is more straightforward, but the second one has the meat of the expression (bar.baz()) more prominently.

top 12 comments
sorted by: hot top controversial new old
[-] MagicShel@programming.dev 5 points 1 year ago* (last edited 1 year ago)

I'd skip the ternary and go with

foo = Optional.ofNullable(bar)
        .map(Bar::baz)
        .orElse(null);

But if I didn't, I'd use the first form.

[-] presumably_wrong@lemm.ee 5 points 1 year ago* (last edited 1 year ago)

In java 9 there is Objects.requireNonNullElse(obj, defaultValue)

[-] JackbyDev@programming.dev 2 points 1 year ago

That wouldn't help in the specific examples above but that's still nice to know about!

[-] JavaCodeWriter@programming.dev 1 points 1 year ago

In java 9 there is Objects.requireNonNullElse(obj, defaultValue)

I did not know this existed, this is amazing.

[-] kmo@feddit.de 4 points 1 year ago

If I had to go with the ternary operator, I would choose not to negate the statement for the sake of readability.

If I had free will of choice I would prefer using the Optionals API, like @MagicShel@programming.dev did.

[-] _MoveSwiftly@lemmy.world 3 points 1 year ago

The first one. Readability is quicker, and you don't have to stack context in your head if it's ==.

Personally though, I prefer what I call short circuiting. Return right away if it's null, basically input sanitization.

[-] austin@programming.dev 3 points 1 year ago

I think generally it’s preferably to work in the affirmative, i.e. bar == null? but I’ll admit I don’t stick to this 100% of the time and generally just use whatever feels better / more appropriate in the moment

[-] triarius@programming.dev 2 points 1 year ago

I think the meat being more prominent in the second one is subjective. If I were writing a method to do something like this with ifs, I would handle the edge cases first and return early from them. The meat would be what's left after the edge cases. So this lines up with the first form.

[-] angrymouse@lemmy.world 1 points 1 year ago* (last edited 1 year ago)

I actually prefer

Optional.of(bar)
    .map(Bar::baz)
    .orElse(null)

You can crucify me but there is no way to miss the point in a quick glance here and I doubt that with JVM optimizations there is any meaningful performance impact, exceptionally in business code.

[-] o11c@programming.dev -2 points 1 year ago

The second, or early return/continue/break.

But don't forget the third option:

foo = null
if (bar != null)
    foo = bar.baz();

This is much more readable if nontrivial; the only downside is that this inhibits the practice of ubiquitous final.

Actually, doesn't Java allow lazy final if you don't initialize (that would require explicit else)? I speak too many languages ...

[-] pohart@lemmyrs.org 3 points 1 year ago* (last edited 1 year ago)

This is much less readable if non-trivial. It's easy enough here, but now I need to search through the code to see where else foo was set.

[-] JackbyDev@programming.dev 1 points 1 year ago

Yes, Java allows lazy final like you say. I also prefer full blown if when it is non trivial or longer than a full line. (Wish we had if-expressions!)

load more comments
view more: next ›
this post was submitted on 28 Jun 2023
8 points (100.0% liked)

Java

1327 readers
4 users here now

For discussing Java, the JVM, languages that run on the JVM, and other related technologies.

founded 1 year ago
MODERATORS